We can confirm that GBP outbound payments are now operating as normal, and all affected payments should have reached their final state. If you have any concerns or are unsure about a specific payment, please contact our Support Team at support@modulrfinance.com.
We sincerely apologise for the inconvenience and disruption this issue may have caused, and we appreciate your understanding while we worked to resolve it.
Posted Jun 16, 2026 - 15:06 BST
Identified
We have identified the root cause and are working as quickly as possible to resolve the issue.
GBP inbound payments are now processing as expected. However, we are still experiencing delays affecting GBP outbound payments, which we are actively working to resolve.
We sincerely apologise for the ongoing disruption and are treating this as a priority. If you require any assistance, please contact support@modulrfinance.com.
Posted Jun 16, 2026 - 14:30 BST
Investigating
We’re currently experiencing delays affecting some GBP inbound and outbound payments, beginning at approximately 1:58pm BST.
Inbound payments will be processed shortly, while we continue to investigate delays impacting outbound payments.
There is no action required on your side at this time. We will post an update here as soon as more information becomes available.
We’re very sorry for any inconvenience this may cause. If you need any further assistance, please contact our Support Team at support@modulrfinance.com.