Inbound Direct Debit Delay
Incident Report for Modulr Finance Limited
Resolved
We have resolved the incident and have had confirmation from our Direct Debit Inbound service provider that the funds due to be collected on the 13th of July will be collected on Monday. The collection schedule statuses for the 13th of July should also be updated on Monday.

We will be monitoring on Monday to ensure all collections are made successfully.

Please accept our apologies for any inconvenience. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jul 15, 2022 - 13:33 BST
Identified
The issue has been identified. Our Direct Debit Inbound service provider has notified us of a file failure which resulted in no collections being successful for the 13th of July. We have asked for additional information as to this has happened. We have also asked for a time frame for when we can expect these collections to be completed.

We will provide an update with further details as soon as we have heard back from them.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jul 15, 2022 - 12:12 BST
Investigating
We are currently experiencing an issue with Direct Debit Inbound Service where collections on the 13th of July appear not to be collected from customers accounts.

This is not impacting our Direct Debit Outbound service and is continuing to operate as normal.

We are looking into this with urgency and will provide an update with further details as soon as we have identified this issue.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jul 15, 2022 - 10:52 BST
This incident affected: Direct Debit Collection Service.