Platform Impacted

Incident Report for Modulr Finance Limited

Resolved

Our 3rd party provider has confirmed service is now running as normal and stable, which we have verified following a period of careful monitoring.

We have implemented heightened monitoring and mitigation on our end also and are now marking this incident as resolved.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com.
Posted 3 years ago. Mar 29, 2022 - 17:15 BST

Update

Our platform is remaining stable at this time.

We are continuing to monitor the situation whilst we wait to receive a full root cause analysis from our 3rd party supplier.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted 3 years ago. Mar 29, 2022 - 16:17 BST

Update

Our platform stability continues at this time.

We will continue to remain in a monitoring state until we receive a full root cause analysis from our 3rd party supplier

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted 3 years ago. Mar 29, 2022 - 15:30 BST

Monitoring

We are seeing improved performance across the impacted API's, whilst we wait for confirmation from our supplier we are continuing monitoring the situation.
Posted 3 years ago. Mar 29, 2022 - 14:56 BST

Identified

Our third party API provider has had reoccurrence of the issue, they are currently working to implement preventative measures to try and combat this issue. We are continuing to work with them and monitoring the situation
Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted 3 years ago. Mar 29, 2022 - 14:33 BST

Monitoring

We are seeing improved performance across the impacted API's, whilst we wait for confirmation from our supplier we are continuing monitoring the situation.
Posted 3 years ago. Mar 29, 2022 - 13:54 BST

Update

We are continuing to work on a fix for this issue.
Posted 3 years ago. Mar 29, 2022 - 13:48 BST

Identified

We have now identified the issue, there is an outage with one of our third party API service provider. We are currently working with the provider and have escalated it to ensure their engineers.
Payment in service is operational as well as our card service authorisation service
Payment Outs service and account creation service is currently impacted and is not functioning.
Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted 3 years ago. Mar 29, 2022 - 13:25 BST

Investigating

We have identified an outage with our API third party service provider.
We currently have our engineers looking and are working to implement a fix.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted 3 years ago. Mar 29, 2022 - 13:22 BST
This incident affected: Faster Payment Service, Modulr Customer Portal, and Modulr API.