Slow Processing of Outbound Payments
Incident Report for Modulr Finance Limited
Resolved
Thank you for your patience.

The incident is now resolved. All payments are now processing normally and in the usual timeframes.

I would like to reiterate our apologies for the inconvenience this is causing.

If you have any questions or concerns please don't hesitate to contact support on support@modulrfinance.com or 03033130060.
Posted May 28, 2020 - 12:43 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2020 - 12:27 BST
Update
In addition to holding our outbound payment queue we will shortly be holding our inbound payment queue in order for us to complete corrective action on our database.

We will keep you updated as we work to resolve this issue.
Posted May 28, 2020 - 12:08 BST
Identified
The issue has been identified and a fix is being implemented.
Posted May 28, 2020 - 11:58 BST
Investigating
We are currently experiencing a delay with our outbound payment service which is resulting in payments taking longer than usual to process. Outbound payments are currently taking roughly 10 minutes to process.

We have just held the outbound payment queue whilst we complete several actions that we believe that will resolve the issue.

Please be assured we are working to resolve this as quickly as possible and we will keep you updated regularly until this matter is resolved.

All inbound payments and our other services are processing normally.

We apologize for any inconvenience this may be causing and thank you for your continued patience whilst we work to resolve this.
Posted May 28, 2020 - 11:43 BST
This incident affected: Faster Payment Service.