Outbound payments held
Incident Report for Modulr Finance Limited
Resolved
We can confirm that payments are now processing as normal.

We sincerely apologise for the inconvenience of this issue.

If you have any questions or concerns please contact support@modulrfinance.com
Posted Jul 25, 2020 - 10:53 BST
Monitoring
We have identified the issue and are working to resolve it as quick as possible.

The payments that were held are now being released and we are monitoring the payments that have failed.

We apologize for any inconvenience this may be causing and thank you for your continued patience whilst we work to resolve this issue.
Posted Jul 25, 2020 - 10:47 BST
Investigating
As of around 10:20 we have been observing and investigating an issue with outbound payments.

Currently all outbound payments are being held due to an issue with our third party provider.

Our technical team are working closely with our Banking Partner to resolve this issue as quickly as possible and we will keep you updated regularly until this matter is resolved.

We apologize for any inconvenience this may be causing and thank you for your continued patience whilst we work to resolve this issue.
Posted Jul 25, 2020 - 10:40 BST
This incident affected: Faster Payment Service.