Delay to some GBP payments scheduled for processing

Incident Report for Modulr Finance Limited

Resolved

We are pleased to confirm that the earlier delays affecting some GBP payments scheduled for today have now been fully resolved.

All affected payments have been successfully processed, and no further action is required from you.

We apologise for any inconvenience this may have caused and thank you for your patience while our teams worked to restore normal service. If you have any questions or need further assistance, please don’t hesitate to contact our Support Team at support@modulrfinance.com.
Posted Feb 27, 2026 - 09:56 GMT

Investigating

We are currently investigating this issue.
Posted Feb 27, 2026 - 03:06 GMT

Monitoring

We’re currently experiencing delays to some GBP payments scheduled for today. Our teams are actively working on the issue, and all affected payments will be processed by 10:30am.

All inbound payments are being processed normally.

We are very sorry for any inconvenience this may cause. If you need further assistance, please contact our Support Team at support@modulrfinance.com.
Posted Feb 27, 2026 - 03:03 GMT
This incident affected: Faster Payment Service.