SEPA Credit Transfer - Payment Delay
Incident Report for Modulr Finance Limited
Resolved
We can confirm that we have identified the cause of the delay in processing outbound SEPA Credit Transfers and this has now been resolved. All effected payments will be processed.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 23, 2023 - 11:58 BST
Investigating
We are currently investigating a delay to outbound Euro payments being processed by SEPA Credit Transfer for our European accounts. Outbound SEPA Instant Payments are still being processed normally.

There is no Impact to Inbound SEPA payments.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 23, 2023 - 11:27 BST
This incident affected: SEPA (Euro) Payment Service.