This incident has been resolved. We can confirm both Inbound and Outbound SEPA instant payments should be processing as expected now.
We can confirm this incident occurred due to an issue experienced with our SEPA provider.
Any Outbound payments which were submitted as SEPA Instant during the outage were re-routed as SEPA Credit Transfers and are expected to be processed on the start of business on Monday (04/08/2025).
We are very sorry for any inconvenience caused by this issue. If you have any further questions please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 01, 2025 - 21:45 BST
Investigating
We are currently investigating an issue with SEPA Instant payments.
SEPA Instant payments that are attempted will be re-routed as SEPA Credit Transfers and are expected to be processed on the start of business on Monday (04/08/2025).
Please be assured we are investigating and working to resolve this matter as quickly as possible.
Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 01, 2025 - 20:22 BST
This incident affected: SEPA (Euro) Payment Service.