Delays on inbound BACS and Direct Debits
Incident Report for Modulr Finance Limited
Resolved
The issue has been resolved.

Inbound BACS payments and Direct Debits have been processed as normal.

For any questions please contact support@modulrfinance.com
Posted Jul 29, 2020 - 10:43 BST
Identified
We are currently undergoing a delay with inbound BACS and Direct Debit payments.

The issue has been identified and we are working towards a fix.

We will continue to send out updates as we progress on this issue.
Posted Jul 29, 2020 - 10:01 BST
This incident affected: Faster Payment Service.