Slow Processing of Outbound Payments
Incident Report for Modulr Finance Limited
Resolved
Thank you for your patience.

The incident is now resolved. Payments have been processing normally since 14:01.

I would like to reiterate our apologies for the inconvenience this is causing.

If you have any questions or concerns please don't hesitate to contact support on support@modulrfinance.com or 03033130060.
Posted May 13, 2020 - 16:31 BST
Update
Thank you for your patience.

The incident is now resolved. Payments have been processing normally since 14:01.

I would like to reiterate our apologies for the inconvenience this is causing.

If you have any questions or concerns please don't hesitate to contact support on support@modulrfinance.com or 03033130060.
Posted May 13, 2020 - 16:30 BST
Update
Thank you for your continued patience.

Outbound payments have been processing normally since 14:01. At the moment we are still monitoring this.

We will be in touch to confirm with this issue is resolved.

I would like to reiterate our apologies for the inconvenience this is causing.

If you have any questions or concerns please don't hesitate to contact support on support@modulrfinance.com or 03033130060.
Posted May 13, 2020 - 15:34 BST
Monitoring
Thank you for your continued patience.

Currently, outbound payments are processing normally. We are continuing to monitor this and will be in touch to confirm when this issue is resolved.

I would like to reiterate our apologies for the inconvenience this is causing.

If you have any questions or concerns please don't hesitate to contact support on support@modulrfinance.com or 03033130060.
Posted May 13, 2020 - 14:11 BST
Investigating
As of 13:20 this afternoon there has been a delay with our outbound payment service which has resulted in payments taking longer than usual to process.

Please be assured we are working to resolve this as quickly as possible and we will keep you updated regularly until this matter is resolved.

All inbound payments are processing normally.

We apologize for any inconvenience this may be causing and thank you for your continued patience whilst we work to resolve this.
Posted May 13, 2020 - 13:20 BST
This incident affected: Faster Payment Service.