Customer Portal Outage
Incident Report for Modulr Finance Limited
Resolved
After our monitoring, we can now confirm that the Customer Portal and Salary Supplier Payments Portal are back in service.
All platform functions are working as normal.
Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Feb 10, 2022 - 16:13 GMT
Update
We can now confirm that the customer portal and salary supplier payments has resumed back to normal functionality. We are still monitoring it to ensure this error does not reappear.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Feb 10, 2022 - 16:06 GMT
Monitoring
We are aware that users of the Customer Portal and Salary Supplier Payments cannot login or make approvals due to an issue we are experiencing with one of our providers. This outage occurred between 15:37 - 15:51

Please be assured that we are looking at this as a priority.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Feb 10, 2022 - 15:55 GMT
This incident affected: Modulr Customer Portal.