Delayed SEPA Credit Transfers
Incident Report for Modulr Finance Limited
Resolved
Update: As of 12:30pm today [16/10/23] we are seeing these delayed payments processing to the beneficiaries and noticing normal service for SEPA Credit Transfers moving forward.

We had identified an issue which was causing outbound SEPA Credit Transfer payments to be delayed in a pending state.

Any other payments methods are unaffected and function as normal.

Our external partner confirm that the underlying issue has been resolved - however any submitted payments via SEPA Credit Transfer from 8am today (13/10/23) will not be processed until Monday. We will continue to monitor this matter in the interim and share any further information, as relevant.

Please accept our apologies for any inconvenience caused and, as ever, should you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Oct 16, 2023 - 12:55 BST
Monitoring
We had identified an issue which was causing outbound SEPA Credit Transfer payments to be delayed in a pending state.

Any other payments methods are unaffected and function as normal.

Our external partner confirm that the underlying issue has been resolved - however any submitted payments via SEPA Credit Transfer from 8am today (13/10/23) will not be processed until Monday. We will continue to monitor this matter in the interim and share any further information, as relevant.

Please accept our apologies for any inconvenience caused and, as ever, should you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Oct 13, 2023 - 17:33 BST
Update
We have identified an issue which is causing outbound SEPA Credit Transfer payments to be delayed in a pending state. We are currently looking to resolve this issue with our payment partner and will update this page accordingly when the issue has been resolved.

Any other payments methods are unaffected and function as normal.

Our external partner continues to work toward a resolution for the underlying issues and we are working with them to aid in resolution.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Oct 13, 2023 - 16:14 BST
Update
Our Euro payments partner is continuing to work towards a resolution on this matter and we continue to liaise with them.

As ever please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Oct 13, 2023 - 14:09 BST
Update
We are still working to resolve an issue which is causing SEPA Credit Transfer payments to be delayed in a pending state. We are currently looking to resolve this issue with our payment partner and will update this page accordingly when the issue has been resolved.

Any other payments methods are unaffected and function as normal.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Oct 13, 2023 - 13:25 BST
Identified
We have identified an issue which is causing outbound SEPA Credit Transfer payments to be delayed in a pending state. We are currently looking to resolve this issue with our payment partner and will update this page accordingly when the issue has been resolved.

Any other payments methods are unaffected and function as normal.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Oct 13, 2023 - 12:13 BST
This incident affected: SEPA (Euro) Payment Service.