Inbound and outbound payment delays
Incident Report for Modulr Finance Limited
Resolved
We are pleased to confirm this incident is now fully resolved. All payments delayed by the degradation of our database have processed and payments are currently processing normally. We are taking immediate action to correct our proactive alerting which failed to alert us to the issue as early as we would have expected in this scenario.

Please accept our apologies for any inconvenience that has been caused by this delay in payment processing, if you require any further detail or support please do let us know: support@modulrfinance.com
Posted Dec 01, 2020 - 16:57 GMT
Monitoring
We have identified the cause of a degradation of performance in our database that we have taken action to resolve. I am pleased to confirm all payments are now processing normally and all payments impacted by this incident have been processed.

We are closely monitoring the changes we have made and will confirm once we have we are confident the incident has been fully resolved.
Posted Dec 01, 2020 - 16:46 GMT
Investigating
We are currently experiencing delays in processing inbound and outbound payments across our Faster payment and Euro payment services. Payments are still being processed, however we are experiencing delays of around 35 minutes.

We have been experiencing this issue since 15:48 today.

All other services are running normally.

We are investigating this as a matter or urgency and will keep you regularly updated whilst we work to resolve this delay. Apologies for any inconvenience this delay in payment processing is causing.
Posted Dec 01, 2020 - 16:36 GMT
This incident affected: Faster Payment Service and SEPA (Euro) Payment Service.