Degraded Performance across Modulr

Incident Report for Modulr Finance Limited

Resolved

This incident has fully resolved and all systems are fully operational.

If you have any further queries regarding this incident, please feel free to reach out to support@modulrfinance.com and we will be able to assist.
Posted Apr 21, 2026 - 15:01 BST

Monitoring

We can confirm that a fix has been deployed for this issue and all systems are fully operational again.

We will continue to monitor to ensure that all systems are steady and no further issues occur.
Posted Apr 21, 2026 - 14:14 BST

Identified

We have identified the issue and are currently working on the resolution. We will update once this is complete.
Posted Apr 21, 2026 - 13:42 BST

Investigating

We are currently experiencing a degraded performance across all Modulr services. We are currently investigating this issue as an urgent issue and we will update when we receive more information.

For any further queries, please reach out to support@modulrfinance.com
Posted Apr 21, 2026 - 13:31 BST
This incident affected: Faster Payment Service, BACS Inbound Service, CHAPS Payment Service, Direct Debit Collection Service, Direct Debit Payment Service, SEPA (Euro) Payment Service, Modulr Customer Portal, Modulr API, Payment Initiation Service (PIS), Twilio Authy App, Twilio Authy 2FA, Confirmation of Payee, Notifications and Card Payment Service (Authorisations, Card Settlement).