Customer Creation Issue

Incident Report for Modulr Finance Limited

Resolved

The issue affecting customer account screening has now been resolved.

Screening is now processing as expected, and all previously impacted accounts are now active.

New customer accounts will continue to be screened and made live automatically following creation.

We apologise for the inconvenience caused and will continue to monitor the situation closely.
Posted May 14, 2026 - 10:41 BST

Monitoring

The issue affecting customer account screening has now been resolved, and screening is processing as expected.

New customer accounts will now be automatically screened and made active following creation.

We are currently working through previously impacted accounts to complete their screening and unblock them.

No action is required from you at this time.

We apologise for the inconvenience caused and will continue to monitor the situation closely.
Posted May 14, 2026 - 10:17 BST

Identified

We have identified the issue affecting customer creation, which is related to the screening of accounts not functioning as expected.

This incident began at approximately 14:27 yesterday.

Customer account creation is currently processing successfully; however, newly created accounts may not yet be fully active due to the screening issue.

Once the issue is resolved, we will automatically complete the screening process and activate all affected accounts.
No action is required from you at this time.

We will continue to provide updates as progress is made.

We apologise for the inconvenience caused. If you require any further support, please contact us at support@modulrfinance.com.
Posted May 14, 2026 - 09:23 BST

Investigating

We are currently investigating an issue affecting customer creation.

As a result, newly created customers may be impacted, and a number of payments have also been affected.

No action is required from you at this time.

Please be assured that our teams are actively working to resolve this issue as quickly as possible. We will continue to provide regular updates as we make progress.

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted May 14, 2026 - 08:15 BST
This incident affected: Modulr API.