Visa Card Settlement Delayed
Incident Report for Modulr Finance Limited
Resolved
The aforementioned incident in relation to Visa card settlement files from last weekend has now been resolved. We have successfully processed the impacted settlement files and all card reconciliation is now up to date with the underlying issue resolved moving forward.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us at: support@modulrfinance.com
Posted Mar 07, 2023 - 10:37 GMT
Identified
We have been unable to process the Visa card settlement file from this weekend due to an issue that we are currently working to resolve. This means that card settlement activity due to take place today has not been completed yet. We expect the issue to be resolved by 12:00pm tomorrow 07/03/2023 and we will provide an update in the morning (or sooner if applicable) regarding this issue.

This issue does not impact any other aspects of our cards service (i.e. authorisations, card creation etc.)

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Mar 06, 2023 - 10:48 GMT
This incident affected: Card Payment Service (Card Settlement).