CHAPS Processing Issue

Incident Report for Modulr Finance Limited

Resolved

Thank you for your patience whilst we worked on this incident with our partner.

The service outage has now been resolved and normal operations have resumed for both Inbound and Outbound CHAPS payments.

Thank you again for your understanding and patience whilst we resolved this issue.

If you encounter any further issues related to this service, please do not hesitate to reach out to our support team at support@modulrfinance.com.
Posted Aug 01, 2025 - 10:38 BST

Investigating

We have been made aware of a system issue with our third party provider for our CHAPS processing and clearing.

We are working closely with our partner to identify the root cause and implement a fix so that we can resume normal operations.

Currently this is impacting both Inbound and Outbound payments.

For Inbound payments, we are not seeing any incoming transfers presently. Once the issue is resolved we can resume receiving incoming transfers.
For Outbound payments, we aim to have this resolved prior to cut-off for today's value date.

Thank you for your patience and understanding whilst we work to get this issue resolved for you. We will keep you updated every hour.
Posted Aug 01, 2025 - 09:42 BST
This incident affected: CHAPS Payment Service.