Intermittent Card 3D Secure Issues
Incident Report for Modulr Finance Limited
Resolved
Following on from the work carried out by our cards processor, and continued monitoring of transaction, we can confirm this issue has now been resolved. Card payments are now processing as expected with no on-going issue with 3D Secure.

As ever Modulr do apologise for any inconvenience caused and should you require any further support around the issue please do reach out to our support team: Support@modulrfinance.com
Posted Apr 17, 2024 - 11:16 BST
Update
We are continuing to monitor for any further issues.
Posted Apr 17, 2024 - 11:12 BST
Monitoring
Our card processor has confirmed that, as of 09:38am, 3D Secure transactions are now processing as expected. They, and ourselves, continue to monitor transactions to ensure resolution.
Posted Apr 17, 2024 - 09:49 BST
Identified
We are currently aware that our card processor is experiencing intermittent failures for 3D Secure Challenges for Card Transactions. They are currently working towards a resolve on this matter and we continue to liaise with them to aid in their resolution.

At present any card transactions which are verified using 3D Secure may intermittently return an unsuccessful response - this wouldn't necessarily entail issue with the underlying card.

We continue to monitor this issue and will share any updates as, and when, these become available.

Please accept our apologies for any inconvenience caused and, as ever, should you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Apr 17, 2024 - 09:24 BST
This incident affected: Card Payment Service (Authorisations).