Customer Portal Unavailable
Incident Report for Modulr Finance Limited
Resolved
We are pleased to confirm that following a period close monitoring we are confident the Cusotmer Portal is now working normally. You will be able to log in and use all the functionality as you normally would.

We have identified that the cause of this incident was related to a technical issue experienced by one of our suppliers.

If you log into the portal and receive an error advising customers/accounts cannot be loaded please refresh your browser. You can do this by pressing F5.

Please accept our apologies for the any inconvenience caused by this incident, and we thank you for your patience whilst this issue was resolved.
Posted Apr 02, 2021 - 08:13 BST
Identified
The cause of this issue has been identified by our 3rd party provider and they are urgently working to resolve it.

We apologize for any inconvenience this may be causing and we will keep you regularly updated as we work to resolve this issue.
Posted Apr 02, 2021 - 07:56 BST
Investigating
Our Customer Portal is currently unavailable. When attempting to login users will be unable to authenticate their login attempt using the authy app.

We apologize for any inconvenience this may be causing and we will keep you regularly updated as we work to resolve this issue.
Posted Apr 02, 2021 - 07:13 BST
This incident affected: Modulr Customer Portal.