Direct Debit Collections - Inbound - Mandate Status Error

Incident Report for Modulr Finance Limited

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 21:52 BST

Update

Thank you for your patience.

The issue affecting Direct Debit Mandates with ACTIVE status since has now been fully resolved. All mandates are correctly reporting their status.

Direct Debit collections for the current input day (value date: 1st October) have been submitted as normal. No further action is required.

If you need any additional information, please contact our Support team at support@modulrfinance.com.
Posted Sep 29, 2025 - 21:51 BST

Identified

We have identified an issue whereby our Direct Debit Management service is returning an incorrect result for all DD Collection mandates (inbound); it is returning a status of "REJECTED".

We are in processof rolling out a fix which we anticipate to be completed prior to today's collections (Bacs input day for collections with value date 1st October).

No action is required on your part for this.

We will let you know if we are unable to implement our fix prior to the deadline collection submission.
To avoid any doubts, and Direct Debit collections currently processing (value date of 30th Sept) will not be affected.

This note is advisory only; up until circa 17:00 if your service/system attempts to synchronise status via the getmandates API at present it will return an incorrect status. As of circa 17:00 we are temporarily disabling the service whilst we roll out the fix to prevent any undue and unanticipated consequences.
Posted Sep 29, 2025 - 17:35 BST
This incident affected: Direct Debit Collection Service.