CoP (Confirmation of Payee) Outage

Incident Report for Modulr Finance Limited

Resolved

We have taken remediation action and can confirm that Outbound Confirmation of Payee service is working as expected.

Please accept our apologies for any inconvenience caused.

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com. Thank you for your patience and understanding.
Posted Oct 24, 2025 - 16:10 BST

Investigating

We are currently investigating an issue with our Outbound Confirmation of Payee service. Currently any name checks being made are responding with a "No Response".

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. We anticipate resolution within the next hour.

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com. Thank you for your patience and understanding.
Posted Oct 24, 2025 - 15:59 BST
This incident affected: Confirmation of Payee.