Inbound FPS delay

Incident Report for Modulr Finance Limited

Resolved

This incident has been resolved.
Posted May 28, 2026 - 18:30 BST

Monitoring

We can confirm that inbound Faster Payments are now flowing as expected and the earlier delay resolved. Outbound payments were not affected at any point during this incident.

We apologise for any inconvenience caused and thank you for your patience while we worked to resolve this matter.

We are continuing to monitor for any further disruptions.

If you have any further questions or require additional support, please don't hesitate to contact us at support@modulrfinance.com.
Posted May 28, 2026 - 18:16 BST

Investigating

We are currently investigating a delay with inbound Faster Payments being applied to accounts, We are currently not seeing a disruption with outbound payments.

Please be assured we are investigating and working with them to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 28, 2026 - 17:24 BST
This incident affected: Faster Payment Service.