Faster Payment Issues
Incident Report for Modulr Finance Limited
Resolved
We can confirm this incident has now been resolved and all Faster Payments will process as normal.

Please accept our apologies for any inconvenience caused.

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
.
Posted May 16, 2021 - 08:17 BST
Monitoring
All faster payments are now being processed successfully.

All delayed payments are currently being processed and will be completed in the next 30 mins.

We are continuing to monitor all payments.

Once again we apologise for the inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com.
Posted May 16, 2021 - 07:59 BST
Update
Inbound payments are now currently processing as normal. We are currently trying to resolve the issue for outbound payments.

We will provide an update for outbound payments in the next hour or sooner.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 16, 2021 - 07:35 BST
Update
We continue work on the certificate issue with our third party

All payments that are submitted will be processed once we resolve this issue.

We will provide you with a further update in the next hour or sooner.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 16, 2021 - 07:09 BST
Update
We continue work on the certificate issue with our third party

All payments that are submitted will be processed but are currently being delayed.

We will provide you with a further update in the next hour or sooner.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 16, 2021 - 06:07 BST
Update
We are currently working with a third party to resolve the ongoing issue.

We will provide an update in the next hour or sooner.

“Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 16, 2021 - 05:12 BST
Update
We are still currently working to resolve the issue.

We will provide another update in an hours time.

“Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 16, 2021 - 04:11 BST
Update
We are still currently working to resolve the issue.

We hope this will be resolved in the next hour.

“Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 16, 2021 - 03:07 BST
Update
We are continuing to work on a fix for the issue identified.

We will provide a further update in the next 30 minutes

“Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 16, 2021 - 02:50 BST
Identified
We are aware of issue with our Faster Payment Scheme - all faster payments are currently impacted. We have located the root cause and are in the process of fixing this.

We will provide an update in the next 30 minutes.

“Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 16, 2021 - 02:17 BST
This incident affected: Faster Payment Service.