SEPA Payments Outage

Incident Report for Modulr Finance Limited

Resolved

We’re happy to confirm that both SEPA Instant and SEPA Credit (inbound and outbound) payments are now flowing as expected and the incident has been resolved.

All impacted payments have reached their final status — either processed or failed. Notifications should have been sent via webhooks accordingly.

We sincerely apologise for any inconvenience this may have caused and appreciate your patience while this was being resolved.

If you have any questions or need further assistance, please contact Support at support@modulrfinance.com.
Posted May 21, 2026 - 11:05 BST

Monitoring

SEPA Instant and Credit inbound and outbound payments are now flowing as expected.

The incident occurred between 11:50pm and 3:48am, during which time the scheme was unavailable.

We apologise for any inconvenience this may have caused. If you have any questions, please don’t hesitate to reach out to support@modulrfinance.com.
Posted May 21, 2026 - 09:24 BST

Update

We are continuing to investigate this incident and have been able to confirm the following:

- All outbound SEPA payments have been effected by this and we have kept our SEPA payments services paused. Outbound payments attempted during this period will be held and not go to scheme.
- We are also seeing intermittent issues with inbound payments where we are seeing some successful payments crediting accounts but also seeing failing payments. We would recommend caution and double checking if a payment has fully credited the intended account.
- We have been able to identify this is due to an issue with our SEPA payments provider and is not an issue directly with Modulr. This has been escalated to them.

Again, we would like to apologise for the inconvenience and we are working to resolve this with our SEPA payments processor.

We will communicate when services have resumed and if you have any further queries regarding this incident, please feel free to reach out to us at support@modulrfinance.com.
Posted May 21, 2026 - 02:02 BST

Investigating

We are currently investigating an issue with SEPA outbound payments where any payments that have been sent to our SEPA scheme provider are currently failing.

While we investigate this and find the root cause, we have paused all outbound SEPA payments. If you attempt to process any payments in this period where payments are paused, they will be held and will not go to scheme.

We are working as quickly as possible to resolve this incident. If you have any further questions, please feel free to reach out to support@modulrfinance.com.
Posted May 21, 2026 - 00:47 BST
This incident affected: SEPA (Euro) Payment Service.