Outbound Payments Response Delays
Incident Report for Modulr Finance Limited
Resolved
We have resolved the issue causing the delay in outbound payment statuses updating. All outbound payment statuses have now updated appropriately.

Please accept at our apologies for any inconvenience caused by this issue and if you require any further detail please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 29, 2020 - 16:34 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 29, 2020 - 16:30 BST
Investigating
All payments are flowing normally, however we are aware that our platform is taking around 15 minutes to update the status of outbound payments. This means that the updating of a payment status on the customer portal, as well as the sending of webhooks, for outbound payments will be delayed. We are investigating this as a matter of priority and will keep you updated until this issue is resolved.

Please accept our apologies for any inconvenience this may be causing.
Posted Jun 29, 2020 - 16:04 BST
This incident affected: Faster Payment Service.