Outbound Payments Held
Incident Report for Modulr Finance Limited
Resolved
I am pleased to advise that this incident has been resolved and outbound payments are flowing normally again. All payments that were held whilst our banking partner worked to resolve their database issue have been processed.

Thank you for your patience whilst we have worked to resolve this matter with our banking partner and apologies for any inconvenience this may have caused.
Posted Feb 15, 2020 - 05:10 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2020 - 04:57 GMT
Identified
Our banking partner is still working on the issue that is impacting our payment service. They have identified the issue relates to the performance of their database and are working to fix it as quickly as possible.

Apologies for the inconvenience caused by the continued disruption to our service.
Posted Feb 15, 2020 - 04:42 GMT
Investigating
As of 03:05 this morning we have been holding all outbound payments whilst we work with our banking partner to resolve an issue with our payment service. Please be assured we are treating this issue as Priority 1 issue and we will keep you updated regularly until this matter is resolved.

Once the issue has been resolved we will release the queued outbound payments.

All inbound payments are processing normally.

We apologize for any inconvenience this may be causing and thank you for your continued patience whilst we work to resolve this
Posted Feb 15, 2020 - 03:45 GMT
This incident affected: Faster Payment Service.