Webhook Payment Notification Error
Incident Report for Modulr Finance Limited
Resolved
We can confirm this incident has been resolved. Any webhooks now received should have the correct information contained in them.

We have stopped the process of resubmitting webhooks due to the possibility of them being handled twice by customers.

If any customer would like us to resend webhooks, please contact support at - support@modulrfinance.com to request this.

We do apologise for any inconvenience this may have caused and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Mar 01, 2024 - 17:46 GMT
Update
A fix has been implemented and any new webhooks received should now have the correct data contained within them.

We have gathered the data for the incorrect webhooks and are proceeding to resubmit them in batches. We will confirm back once this action has been complete.

We do apologise for any inconvenience this may have caused and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Mar 01, 2024 - 16:40 GMT
Update
A fix has been implemented and any new webhooks received should now have the correct data contained within them.

We are still gathering the data for the incorrect webhooks to resubmit and we will confirm back once complete.

We do apologise for any inconvenience this may have caused and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Mar 01, 2024 - 16:03 GMT
Monitoring
A fix has been implemented and any new webhooks received should now have the correct data contained within them.

We are still gathering the data for the incorrect webhooks to resubmit and we will confirm back once complete.

We do apologise for any inconvenience this may have caused and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Mar 01, 2024 - 14:48 GMT
Identified
We have identified an issue with our Payment Webhook notifications. Customers may be receiving webhooks with the incorrect information being provided in them.

We are in the process of making an urgent fix and we anticipate this will be deployed in the next 15 minutes.

We will look to gather the data for the incorrect webhooks and resubmit them

We do apologise for any inconvenience this may have caused and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Mar 01, 2024 - 14:42 GMT
This incident affected: Notifications.