Sepa Instant Payment Outage

Incident Report for Modulr Finance Limited

Resolved

This incident has been resolved. We can confirm SEPA instant payments are processing as expected now.

We can confirm this incident occurred due to an issue experienced with our SEPA provider.

Any payments which were submitted as Sepa Instant prior to 2pm have now been processed via Sepa Credit Transfer.

We are very sorry for any inconvenience caused by this issue. If you have any further questions please do not hesitate to contact us: support@modulrfinance.com
Posted May 21, 2025 - 15:05 BST

Update

We can confirm we are now seeing successful SEPA Instant Transactions both Inbound and Outbound.

Any SEPA instant payments that went into a pending state from 8.10am until 14.00 should now have processed as Sepa Credit.

We can confirm this incident occurred due to an issue with our SEPA provider, who are continuing to investigate the root cause.

We are investigating what remediation actions need to be taken and we will be in touch with a further update on this.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 21, 2025 - 14:38 BST

Update

We are continuing to investigate an issue with both Inbound and Outbound SEPA Instant payments. These SEPA Instant payments have been failing since around 08.10am this morning and this is being investigated by our scheme provider.

We can confirm that we have now started to see successful Sepa Instant transfers being processed and will continue to monitor this for a further update from Scheme, For SEPA Instant payments which are failing, these will be re-routed as Sepa Credit transfers if submitted prior to the Sepa Credit transfer cut off time (2pm). These are expected to process as same day payments however Payments submitted post 2pm are expected to process as next day payment.

Please be assured we are investigating and working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 21, 2025 - 12:22 BST

Investigating

We are currently investigating an issue with both Inbound and Outbound SEPA Instant payments.

We have identified that this was first experienced at 8.10am.

SEPA Instant payments that are attempted will be re-routed as Sepa Credit Transfers and are expected to be processed by end of business today if submitted prior to the 2pm cut off time. Payments submitted post 2pm are expected to be processed as next day payments.

Please be assured we are investigating and working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 21, 2025 - 10:53 BST
This incident affected: SEPA (Euro) Payment Service.