We’re pleased to confirm that the issue affecting SEPA Instant payments has now been resolved, and we have been working closely with our Banking Partner throughout.
Any outbound payments that failed during this period with an ER_EXTSYS status can be safely retried.
For payments currently in ER_EXTCONN/processing status, please wait until they progress to final status before attempting a retry.
We will continue to monitor performance closely. Thank you for your patience during this disruption.
Posted May 17, 2026 - 04:44 BST
Investigating
We are currently investigating an issue affecting outbound SEPA Instant payments, which began at 1:50 a.m. BST today.
Our teams are actively working with our banking partner to identify the root cause and resolve the issue as quickly as possible.
No action is required at this moment in time, we will keep you updated here.
We sincerely apologise for any inconvenience this may cause. If you need further support or have any questions, please contact us at support@modulrfinance.com
Posted May 17, 2026 - 03:36 BST
This incident affected: SEPA (Euro) Payment Service.