Outbound payments held
Incident Report for Modulr Finance Limited
Resolved
This incident has now been resolved.

We have had confirmation from our Banking Partner and technical operations team that all outbound and inbound payments are now processing successfully. Any pending payments as a result of this incident are now being processed.

Please check any payments that were due to go out in the last 2 hours, If you have any queries or require assistance then please contact us.

We apologize for any inconvenience this has caused.
Posted Feb 24, 2020 - 04:43 GMT
Update
We are continuing to investigate this issue.
Posted Feb 24, 2020 - 03:52 GMT
Investigating
Natwest group are currently undergoing an incident and all payments to that Banking Group are failing.

Customer will need to retry those payments once the incident is resolved.

Sort codes affected: 04-00-72 & 04-00-83

Current scheduled time of this is 05:30am
Posted Feb 24, 2020 - 03:49 GMT
This incident affected: Faster Payment Service.