Delayed SEPA Credit Transfer Processing
Incident Report for Modulr Finance Limited
Resolved
All SEPA Credit transfers that were in a pending state from IE IBANS submitted post-midday (1200) on 20/02 have all processed.

We can now consider this resolved and all SEPA Credit transfers are functioning as expected.

Please accept our apologies for any inconvenience caused and, as ever, should you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Feb 21, 2024 - 15:45 GMT
Monitoring
We are now seeing payments for our IE IBANs, outbound SEPA Credit Transfer requests submitted post-midday (1200) on 20/02 in a processed state. Any payments affected by this incident have now been processed by our SEPA provider.

We do apologise for any inconvenience this may have caused and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Feb 21, 2024 - 13:11 GMT
Update
Identified - Modulr are aware of an issue today whereby, for our IE IBANs, outbound SEPA Credit Transfer requests submitted post-midday (1200) on 20/02 remain in a pending status and will not process until later today. We are currently reviewing the underlying issue but we can confirm that these payments will process today.

This has no impact on SEPA Instant and solely impacts SEPA Credit Transfer Outbound Payments.

We will provide a further update at 2pm. We do apologise for any inconvenience this may cause and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Feb 21, 2024 - 12:21 GMT
Update
Identified - Modulr are aware of an issue today whereby, for our IE IBANs, outbound SEPA Credit Transfer requests submitted post-midday (1200) on 20/02 remain in a pending status and will not process until later today. We are currently reviewing the underlying issue but we can confirm that these payments will process today.

This has no impact on SEPA Instant and solely impacts SEPA Credit Transfer Outbound Payments.

We will provide a further update at 12pm. We do apologise for any inconvenience this may cause and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Feb 21, 2024 - 10:00 GMT
Identified
Modulr have become aware of an issue today whereby, for our IE IBANs, outbound SEPA Credit Tranfer requests submitted post-midday (1200) remain in a pending status and will not process until tomorrow morning. We are currently reviewing the underlying issue but we can confirm that these payments will process tomorrow.

This has no impact on SEPA Instant and solely impacts SEPA Credit Transfer.

We will provide a further update at 10am tomorrow. We do apologise for any inconvenience this may cause and for any questions related to this outage, please contact us: support@modulrfinance.com
Posted Feb 20, 2024 - 17:08 GMT
This incident affected: SEPA (Euro) Payment Service.