Modulr Payments Outage
Incident Report for Modulr Finance Limited
Resolved
We can confirm all remediation work has been complete and our platform is processing transactions as expected.

We are very sorry for any inconvenience caused by this issue and the length it time it took to resolve. If you have any further questions please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 17, 2024 - 17:38 GMT
Update
We are still working on remediating inbound payments. We will be in touch with a further update once this has been complete.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 17, 2024 - 17:04 GMT
Update
Inbound payments are still being remediated. We will be in touch with a further update once this has been complete.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 17, 2024 - 16:17 GMT
Update
A fix has been implemented and we are now seeing successful inbound and outbound transactions.

For any outbound payment calls made to our api that failed, these payments will need to be retried. Inbound payments are still being remediated. We will be in touch with a further update on this.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 17, 2024 - 15:45 GMT
Monitoring
A fix has been implemented and we are now seeing successful inbound and outbound transactions.

We are investigating what remediation actions need to be taken and we will be in touch with a further update on this.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 17, 2024 - 15:24 GMT
Investigating
We are currently experiencing an issue with our payments platform. This is impacting all Faster Payments, CHAPS and SEPA payments.

We are urgently investigating this issue with our engineering teams.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 17, 2024 - 14:58 GMT
This incident affected: Faster Payment Service, CHAPS Payment Service, and SEPA (Euro) Payment Service.