Customer portal unavailable
Incident Report for Modulr Finance Limited
Resolved
We are pleased to confirm that the Customer Portal and Salary Supplier Payments Portal are fully operational following a brief outage. We have identified the cause of the outage and we are satisfied that the issue has been fully resolved.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 24, 2022 - 15:14 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2022 - 15:09 BST
Investigating
We are aware that users of the Customer Portal and Salary Supplier Payments cannot login or make approvals.

Please be assured that we are looking at this as a priority.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 24, 2022 - 15:07 BST
This incident affected: Modulr Customer Portal.