SEPA Credit Transfer Payment Delay
Incident Report for Modulr Finance Limited
Resolved
I can confirm the incident has now been resolved. Any payments pending from this morning should now be processed.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Sep 11, 2023 - 12:47 BST
Monitoring
Our European Payments Processor have confirmed SCT payments are now being processed. There may be a small delay in the processing, the backlog of payments.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Sep 11, 2023 - 12:00 BST
Update
We are continuing to work with our European Payment Processor, who have confirmed they are experiencing an issue with SEPA Credit Transfer Payments being delayed. We are in contact with them and are awaiting further updates.

Outbound SEPA Instant Payments are still being processed normally.

There is no Impact to Inbound SEPA payments.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Sep 11, 2023 - 11:36 BST
Identified
Our European Payment Processor has confirmed they are experiencing an issue with SEPA Credit Transfer Payments being delayed. We are in contact with them and are awaiting further updates.

Outbound SEPA Instant Payments are still being processed normally.

There is no Impact to Inbound SEPA payments.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Sep 11, 2023 - 10:33 BST
Investigating
We are currently investigating a delay to outbound Euro payments being processed by SEPA Credit Transfer for our European accounts. Outbound SEPA Instant Payments are still being processed normally.

There is no Impact to Inbound SEPA payments.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Sep 11, 2023 - 09:29 BST
This incident affected: SEPA (Euro) Payment Service.