Payment Processing Slowdown
Incident Report for Modulr Finance Limited
Resolved
Thank you for your patience with this incident.

I can confirm this is now resolved.

Should you have any questions please don't hesitate to contact us on support@modulrfinance.com or 03033130060.
Posted May 22, 2020 - 06:17 BST
Monitoring
Thank you for your patience.

I am pleased to confirm that we have cleared the held payments and payments are now processing as we would expect.

We are continuing to monitor this incident and will be in touch to confirm when we believe this to be resolved.

I would like to reiterate our apologies for the inconvenience of this.

If you have any questions or concerns please contact us on support@modulrfinance.com or on 03033130060.
Posted May 22, 2020 - 06:15 BST
Update
We are continuing to investigate the issue.

Payments in and out since 05:30 are flowing as per normal while we work to clear a backlog of inbound payments from 3am and outbound payments from 4am.

We're very sorry for any inconvenience caused.

If you have a specific issue please contact us at Support@modulrfinance.com
Posted May 22, 2020 - 05:33 BST
Update
Thank you for your patience so far.

We are continuing to investigate the issue.

Payments in and out since 05:30 are flowing as per normal while we work to clear a backlog of inbound payments from 3am and outbound payments from 4am.

If you have any questions or concerns please don't hesitate to contact us on support@modulrfinance.com
Posted May 22, 2020 - 05:33 BST
Investigating
Please be aware we are currently investigating issues with our payment processing times.

We've held our payments queues since 4am as part of our ongoing investigation and will provide a further update within an hour.

We're very sorry for any inconvenience caused.

If you have a specific issue please contact us at Support@modulrfinance.com
Posted May 22, 2020 - 04:33 BST
This incident affected: Faster Payment Service.