Payment Processing Slowdown
Incident Report for Modulr Finance Limited
Resolved
I am pleased to confirm that this incident has now been resolved and all payments are now processing normally. No payments failed to process due to this incident.

I would like to apologize for any inconvenience the delay in processing payments may have caused.
Posted May 27, 2020 - 16:26 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 27, 2020 - 16:13 BST
Investigating
Please be aware we are currently investigating issues with our payment processing times.

We've held our payments queues as part of our ongoing investigation and will provide a further update within an hour.

We're very sorry for any inconvenience caused.

If you have a specific issue please contact us at Support@modulrfinance.com or 03033130060.
Posted May 27, 2020 - 15:27 BST
This incident affected: Faster Payment Service.