SEPA Payment Delays
Incident Report for Modulr Finance Limited
Resolved
This incident has now been resolved. Any impacted payments have been remediated and account service & SEPA payments service both inbound and outbound are functioning as expected. We do apologise again for any issues that may have arisen as part of this. As ever, should you require further support, please do get in touch on support@modulrfinance.com
Posted Aug 08, 2023 - 13:49 BST
Update
We have seen no further SEPA Instant issues since 09:24am this morning. As normal service has resumed we will pro-actively monitor this situation. As ever our team are working on remediating payments impacted. We await further update from our screening service provider as to the root cause of the issue itself. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 08, 2023 - 13:18 BST
Update
We have seen no further SEPA Instant issues since 09:24am this morning. As normal service has resumed we will pro-actively monitor this situation. As ever our team are working on remediating payments impacted. We await further update from our screening service provider as to the root cause of the issue itself. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 08, 2023 - 12:17 BST
Update
We have seen no further SEPA Instant issues since 09:24am this morning. As normal service has resumed we will pro-actively monitor this situation. As ever our team are working on remediating payments impacted. We await further update from our screen service provider as to the root cause of the issue itself. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 08, 2023 - 11:28 BST
Monitoring
We have seen no further SEPA Instant issues since 09:24am this morning. As normal service has resumed we will pro-actively monitor this situation. As ever our team are working on remediating payments impacted. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 08, 2023 - 10:37 BST
Update
We are continuing to review this matter and carry out remediation on any impacted payments. We are noticing SEPA Instant payments flowing as expected however continue to monitor.
Posted Aug 08, 2023 - 10:33 BST
Identified
We are currently investigating an issue whereby outbound and inbound SEPA payments are experiencing delays, with issues arising around customer creation and POO payment delays also. This is due to an outage with our screening service provider and we await further update from themselves.

SEPA payments will be currently entering a pending status until our service resumes again. Any inbound payments will also potentially experience delays. Attempts to create customers will fail whilst the issue is worked on. Faster Payments continue to function as normal.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 08, 2023 - 09:34 BST
This incident affected: SEPA (Euro) Payment Service.