Faster Payments Issue
Incident Report for Modulr Finance Limited
Resolved
This issue has now been resolved and payments services are returned to normal.

We can confirm all Inbound and Outbound Payments are now processing successfully.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Mar 26, 2022 - 11:28 GMT
Investigating
We are experiencing a issues with processing Faster Payments. All GBP outbound payments are currently being queued and we are unable to receive inbound GBP payments.

We advise customers not to reattempt inbound our outbound payments as they will be processed once resolved.

We are investigating this issue with our payment’s processor.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Mar 26, 2022 - 11:07 GMT
This incident affected: Faster Payment Service.