Visa Card Settlement Delayed
Incident Report for Modulr Finance Limited
Resolved
This incident has now been resolved.

All delayed settlement activity has now completed on our cards.

Please accept our apologies for any inconvenience caused .If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 16, 2022 - 13:11 BST
Update
We are continuing to work with our card processor in order to fix the Visa Card Settlement file. We expect the issue to be resolved shortly and a further update will be provided in the next 2 hours.

This issue does not impact any other aspects of our cards service (i.e. authorisations, card creation etc.).

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 16, 2022 - 11:43 BST
Identified
We have been unable to process the Visa card settlement file for the 11th and 12th of August due to an issue that we are currently working to resolve. This means that card settlement activity due to take place today has not been completed yet. We expect the issue to be resolved tomorrow morning and we will provide an update in the morning regarding this issue.

This issue does not impact any other aspects of our cards service (i.e. authorisations, card creation etc.).

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 15, 2022 - 16:53 BST
This incident affected: Card Payment Service (Card Settlement).