Inbound and Outbound Payments Being Held
Incident Report for Modulr Finance Limited
Resolved
Thank you for your patience.

We can confirm that this incident has now been resolved and all payments are processing normally.

If you have any questions please don't hesitate to contact support on support@modulrfinance.com
Posted Jun 26, 2022 - 11:26 BST
Monitoring
Thank you for your patience.

Payments are now processing as normal. We are monitoring to ensure full stability for inbound and outbound.

All failed payments are now safe to retry.


If you have any questions please don't hesitate to contact support on support@modulrfinance.com.
Posted Jun 26, 2022 - 11:22 BST
Investigating
We are currently experiencing a connection issue with our platform and we have held both our outbound and inbound payment whilst we continue investigating. This is affecting all GBP payments.

We are looking into this with urgency and will provide an update with further details as soon as we have identified this issue and deployed a fix.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 26, 2022 - 11:12 BST
This incident affected: Faster Payment Service.