Degradation in Service Causing Payments to be Delayed
Incident Report for Modulr Finance Limited
Resolved
This issue has now been resolved and payments services are returned to normal.

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 21, 2022 - 09:12 GMT
Monitoring
We have been experiencing a degradation in our payments service that has caused a number of delays in both outbound and inbound payments.

On average payments were delayed for approximately 2 minutes.

Payments are now processing as expected and we are monitoring this situation at the moment to ensure that the situation has been resolved.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 21, 2022 - 09:06 GMT
This incident affected: Faster Payment Service.