Card Creation Issue
Incident Report for Modulr Finance Limited
Resolved
Our 3rd party provider has identified and fixed the root cause. We are continuing to monitor all systems to make sure everything is stable.

Please accept our apologies for any inconvenience caused

Thank you once again for your patience. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 30, 2021 - 19:49 GMT
Monitoring
Our 3rd party provider has identified and fixed the root cause. We are continuing to monitor all systems to make sure everything is stable.

Please accept our apologies for any inconvenience caused

Thank you once again for your patience. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 30, 2021 - 19:47 GMT
Update
Our 3rd party partner is continuing to investigate the issue. We are sorry for the inconvenience caused and we thank you for your continued patience.

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 30, 2021 - 18:41 GMT
Investigating
We are currently experiencing an issue with a 3rd party in relation to debit cards. This is currently impacting the creation, cancellation and blocking of cards.

There is no impact in the authorisation of card payments.

Please be assured we are working to resolve this as quickly as possible and will keep you regularly updated as we work to resolve this issue.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jan 30, 2021 - 17:39 GMT
This incident affected: Card Payment Service (Authorisations).