Customer Portal Unavailable
Incident Report for Modulr Finance Limited
Resolved
Folowing a period of monitoring We are pleased to confirm that the Customer Portal and Salary Supplier Payments Portal are fully operational following this outage. We have identified the cause of the outage and we are satisfied that the issue has been fully resolved.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Sep 08, 2022 - 15:59 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2022 - 14:42 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 08, 2022 - 14:40 BST
Update
We are continuing to investigate this issue as a matter of priority and we hope to resolve this issue shortly.

We will post updates as soon as we receive them and will provide an update at least once per hour.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Sep 08, 2022 - 14:38 BST
Investigating
We are aware that users of the Customer Portal and Salary Supplier Payments cannot currently login into the portal.

Please be assured that we are looking into this issue as a priority and will keep you regularly updated as we work to resolve this issue.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Sep 08, 2022 - 13:38 BST
This incident affected: Modulr Customer Portal.