Issue affecting customer portal and API

Incident Report for Modulr Finance Limited

Update

Our incident team is still working to resolve the current performance issue as a matter of urgency.

We are observing a degree of improvement in our platform's performance. However, Whilst we work to restore performance, you may still experience:

- Intermittent failures when accessing the portal or API
- Slower-than-normal responses to portal and API requests
- Delays in some payments being processed
- Card authorisation failures due to timeouts (as card authorisations are processed in real time, they may time out rather than queue)

Processing of all inbound and outbound transactions is still currently paused while we urgently work to restore performance

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 27, 2026 - 22:06 BST

Identified

Our incident team is still working to resolve the current performance issue as a matter of urgency. They are currently improving the performance of one of our key databases, which is the root cause of the issue.

Whilst we work to restore performance, you may still experience:

- Intermittent failures when accessing the portal or API
- Slower-than-normal responses to portal and API requests
- Delays in some payments being processed
- Card authorisation failures due to timeouts (as card authorisations are processed in real time, they may time out rather than queue)

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 27, 2026 - 21:08 BST

Update

Our incident team is still working to resolve the current performance issue as a matter of urgency. They are currently improving the performance of one of our key databases, which is the root cause of the issue.

Whilst we work to restore performance, you may still experience:

- Intermittent failures when accessing the portal or API
- Slower-than-normal responses to portal and API requests
- Delays in some payments being processed
- Card authorisation failures due to timeouts (as card authorisations are processed in real time, they may time out rather than queue)

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 27, 2026 - 20:16 BST

Update

Our incident team is working to resolve the current performance issue as a matter of urgency. They are currently improving the performance of one of our key databases, which is the root cause of the issue.

As part of this effort, we have paused the processing of all inbound and outbound transactions. All payment requests sent since 17:50 BST have been queued and will be processed once performance has returned to normal.

Payments requested prior to this time that have not been processed, and are therefore in a "pending" state, should not be reattempted. We will process these payments to their final status as soon as possible once the performance issue is resolved.

Whilst we work to restore performance, you may experience:

- Intermittent failures when accessing the portal or API
- Slower-than-normal responses to portal and API requests
- Card authorisation failures due to timeouts (as card authorisations are processed in real time, they may time out rather than queue)

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 27, 2026 - 19:03 BST

Update

We wanted to give you an update: our engineers are still investigating the issue affecting our customer portal and API. We are taking actions to improve performance and we will continue to provide updates regarding the progress of our resolution effort. Customers may still experience:

- Intermittent failures when accessing the portal or API
- Slower-than-normal responses to portal and API requests
- Delays in some payments being processed

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 27, 2026 - 18:01 BST

Investigating

We are currently investigating an issue affecting our customer portal and API. Customers may experience:

- Intermittent failures when accessing the portal or API
- Slower-than-normal responses to portal and API requests
- Delays in some payments being processed

We understand the impact this may have on your operations and are treating this as a high-priority incident. Our teams are working urgently to identify the cause and fully restore normal service as quickly as possible.

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 27, 2026 - 16:59 BST
This incident affects: Modulr Customer Portal and Modulr API.