The issue affecting customer screening has now been resolved.
Screening is now processing as expected, and all previously impacted customers are now active.
New customer accounts will continue to be screened and made live automatically following creation.
We apologise for any inconvenience caused and appreciate your patience. If you require further support, please contact us at support@modulrfinance.com.
Posted Aug 01, 2026 - 16:02 BST
Monitoring
Our Incident team is actively monitoring performance and continues to observe major ongoing improvements. Our third-party automated screening service provider has confirmed that they are currently investigating an issue within their infrastructure that is impacting service performance.
We will continue to provide updates as progress is made and remain actively engaged until resolution.
We apologise for any inconvenience caused and appreciate your patience. If you require further support, please contact us at support@modulrfinance.com.
Posted Aug 01, 2026 - 08:15 BST
Identified
We are currently experiencing an intermittent issue affecting the onboarding flow for new customer creation using our API. Customer records are being created successfully; however, customers are placed into a “blocked” status, preventing account opening for the affected customers.
We have identified the issue affecting customer creation, which is related to the screening of accounts not functioning as expected.
Our incident team is working as quickly as possible to resolve this and we will provide a further update shortly.
We sincerely apologise for the disruption caused and understand the impact this may have. If you require further support, please contact support@modulrfinance.com.