SEPA Payment Delays
Incident Report for Modulr Finance Limited
Resolved
We can confirm that this incident has now been resolved. Any SEPA Instant payments submitted will process in the standard timeframes expected, there will be no on-going impact.

Any payments impacted during this issue, which fell into a pending status will continue to be remediated moving forward. For any account creation difficulties stemming from this we will also be continuing to work toward remediation.

As prior please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 07, 2023 - 21:12 BST
Update
We are seeing SEPA Instant payments flowing once again however we are continuing to monitor the situation.

Please accept our apologies for any inconvenience caused and should you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 07, 2023 - 20:24 BST
Monitoring
As of 18:06 the overarching issue appears to have been resolved. We are continuing to monitor moving forward.
Posted Aug 07, 2023 - 19:23 BST
Investigating
We are currently investigating an issue with SEPA outbound and inbound payments remaining in a pending status. We are also aware of failures experienced with creating customers at this time. This is due to an outage with our screening provider.

SEPA payments will be currently entering a pending status until our service resumes again. Any inbound payments will also potentially experience delays. Attempts to create customers will fail whilst the issue is worked on.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Aug 07, 2023 - 17:58 BST
This incident affected: SEPA (Euro) Payment Service.