Issue affecting customer portal and API

Incident Report for Modulr Finance Limited

Resolved

We are pleased to confirm that the platform incident has been fully resolved. All systems are operating normally and performance has returned to expected levels

We sincerely apologise for any inconvenience this may cause, If you require any further assistance or have concerns about your payments, please contact our support team at support@modulrfinance.com.
Posted Jul 23, 2026 - 21:56 BST

Update

Platform performance has returned to expected levels, and services are operating normally. We are continuing to closely monitor performance across all systems to ensure stability is maintained.

Our teams are also working as a matter of urgency to resolve the remaining payments currently in a pending state. Customers with payments still showing as Pending should not reprocess them at this time while we complete this work.

Payment guidance:
- Payments affected by this incident that are marked as Failed are safe to retry.
- Payments that remain in a Pending state should not be reprocessed at this time.

We will continue to provide updates as progress is made and remain actively engaged until all impacted payments have been fully resolved.

We apologise for any inconvenience caused and appreciate your patience. If you require further support, please contact us at support@modulrfinance.com.
Posted Jul 23, 2026 - 15:24 BST

Monitoring

We are continuing to observe improved platform performance, and services are operating more normally. While the situation has stabilised significantly, we are maintaining enhanced monitoring to ensure all systems continue to perform as expected.

Customers may still experience isolated delays while we work through the remaining impacted transactions.

Payment guidance:
- If any payments affected by this incident are marked as Failed, they are now safe to retry.
- If payments remain in a Pending state, please do not reprocess them at this time while we continue to work through those transactions.

Our teams remain actively engaged and are monitoring the platform closely until we are confident the incident has been fully resolved.

We appreciate your patience and apologise for any inconvenience caused. If you require further support, please contact us at support@modulrfinance.com.
Posted Jul 23, 2026 - 13:59 BST

Update

We are observing a degree of improvement in our platform's performance; however, customers may still experience:
- Intermittent failures when accessing the portal or API
- Slower-than-normal responses to portal and API requests
- Delays in some payments being processed

We understand the impact this may have on your operations and are treating this as a high-priority incident. Our teams are working urgently to identify the cause and fully restore normal service as quickly as possible.

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 23, 2026 - 13:21 BST

Update

We wanted to give you an update: our engineers are still investigating the issue affecting our customer portal and API. In the meantime, you will experience intermittent API responses and delays in some payments going through.

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 23, 2026 - 12:27 BST

Investigating

We are currently investigating an issue affecting our customer portal and API.

Please be assured that our teams are actively working to resolve this issue as quickly as possible. We will continue to provide regular updates as we make progress.

We sincerely apologise for any inconvenience this may cause. If you require any further support, please do not hesitate to contact us at support@modulrfinance.com.
Posted Jul 23, 2026 - 11:58 BST
This incident affected: Modulr Customer Portal and Modulr API.