Outbound Payments Pending
Incident Report for Modulr Finance Limited
Resolved
The incident is now resolved. Outbound payments now reflect their correct statuses. In summary, outbound payments from around 3am were being sent, however we were not processing the message confirming the payment had been completed which meant payments were showing as pending. We have identified that this was caused by a load issue on our database which we are currently reviewing, and we will be making changes to our proactive alerting to ensure that we avoid any delays in recognizing similar issues in the future.

I would like to reiterate our apologies for the inconvenience this is causing.

If you have any questions or concerns please don't hesitate to contact support on support@modulrfinance.com or 03033130060.
Posted May 29, 2020 - 08:03 BST
Update
We can confirm that the payments impacted by this issue were sent within the usual time-frames however our platform was unable to process the response message to the payment being made. This is why the payments have been showing as pending. I can confirm that all payments showing in pending have now had their statuses updated to reflect their true end state.
Posted May 29, 2020 - 07:51 BST
Monitoring
Outbound payments are now beginning to process. As soon as we are in a position to confirm all outstanding payments have completed we will confirm this.
Posted May 29, 2020 - 07:31 BST
Identified
The issue has been identified and a fix is being implemented.
Posted May 29, 2020 - 07:25 BST
Investigating
As of around 3am this morning we have experienced an issue processing outbound payments causing payments to become stuck in a 'pending' state. We would normally expect our alerting services to have highlighted this issue earlier therefore we will be investigating why this has not happened once the immediate issue has been resolved.

Please be assured we are working to resolve this issue as quickly as possible and we will keep you updated regularly until this matter is resolved.

All inbound payments and our other services are working normally.

We apologize for any inconvenience this may be causing and thank you for your continued patience whilst we work to resolve this.
Posted May 29, 2020 - 07:15 BST
This incident affected: Faster Payment Service.