SEPA Inbound and Outbound Payments Failing To Process from Modulr ES and FR IBANS

Incident Report for Modulr Finance Limited

Resolved

The issue causing errors to inbound and outbound SEPA payments from ES / FR has now been resolved.

We can confirm that ES and FR IBAN’s will now be able to process both inbound and outbound SEPA credit and instant payments.

All payments from ES and FR IBANS which failed during this incident can now be retried.

Please accept our apologies for any inconvenience caused and please be assured we are working to remediate this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 13, 2025 - 09:10 BST

Update

We are continuing to experience an issue with outbound SEPA payments from our FR and ES IBAN Modulr accounts. These are currently not processing. this has been ongoing since 06.00am BST.

All SEPA Credit Payments submitted prior to the 2pm cut off time will not be processed as same day payments, these will be retried by us within the first available window and as such will not need to be resubmitted.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transactions flowing through our NL, IE and GB Modulr accounts are not impacted.

We have identified the underlying cause and are actively working to resolve this matter as quickly as possible.

Our expectation is for the resolution to be completed tomorrow morning (13th of June).

There will be no further status updates regarding this issue until tomorrow morning. We will provide an update at 9AM.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 17:00 BST

Update

We are continuing to experience an issue with outbound SEPA payments from our FR and ES IBAN Modulr accounts. These are currently not processing. this has been ongoing since 06.00am BST.

All Sepa Credit Payments submitted prior to the 2pm cut off time will not be processed as same day payments, these will be retried by us within the first available window and as such will not need to be resubmitted.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transactions flowing through our NL, IE and GB Modulr accounts are not impacted.

We have identified the underlying cause and are actively working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 16:24 BST

Update

We are continuing to experience an issue with outbound SEPA payments from our FR and ES IBAN Modulr accounts. These are currently not processing. this has been ongoing since 06.00am BST.

All Sepa Credit Payments submitted prior to the 2pm cut off time will not be processed as same day payments, these will be retried by us within the first available window and as such will not need to be resubmitted.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transactions flowing through our NL, IE and GB Modulr accounts are not impacted.

We have identified the underlying cause and are actively working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 15:20 BST

Update

We are continuing to experience an issue with outbound SEPA payments from our FR and ES IBAN Modulr accounts. These are currently not processing. this has been ongoing since 06.00am BST.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transactions flowing through our NL, IE and GB Modulr accounts are not impacted.

We have identified the underlying cause and are actively working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 14:06 BST

Update

We are continuing to experience an issue with outbound SEPA payments from our FR and ES IBAN Modulr accounts. These are currently not processing. this has been ongoing since 06.00am BST.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transactions flowing through our NL, IE and GB Modulr accounts are not impacted.

We have identified the underlying cause and are actively working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 13:04 BST

Update

We are continuing to experience an issue with outbound SEPA payments from our FR and ES IBAN Modulr accounts. These are currently not processing. this has been ongoing since 06.00am BST.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transactions flowing through our NL, IE and GB Modulr accounts are not impacted.

We have identified the underlying cause and are actively working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 12:02 BST

Update

We are continuing to experience an issue with outbound SEPA payments from our FR and ES IBAN Modulr accounts. These are currently not processing. this has been ongoing since 06.00am BST.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transactions flowing through our NL, IE and GB Modulr accounts are not impacted.

We have identified the underlying cause and are actively working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 11:00 BST

Identified

We are continuing to experience an issue with outbound SEPA payments from our FR and ES IBAN Modulr accounts. These are currently not processing. this has been ongoing since 06.00am BST.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transactions flowing through our NL, IE and GB Modulr accounts are not impacted.

We have identified the underlying cause and are actively working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 10:01 BST

Investigating

We are aware that attempts to make outbound SEPA payments from our FR and ES IBAN Modulr accounts are currently not processing due to an issue we are experiencing with our SEPA service. This started at 6.00am BST.

Any inbound SEPA payments made to a FR or ES IBAN will likely fail until this issue is resolved.

Please be assured that all transaction flowing through our NL, IE and GB Modulr accounts are not impacted.

Please be assured we are investigating this issue as a priority and are working to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 12, 2025 - 08:57 BST
This incident affected: SEPA (Euro) Payment Service.