Customer Portal Authy Issue
Incident Report for Modulr Finance Limited
Resolved
Thank you for your patience during this time.

After an extended monitoring period we are happy to report Customer Portal approvals via Authy are back in service.

The outage was caused by a service interruption with Authy's US East Coast data centre. Authy is continuing to monitor performance and we will provide any further developments where necessary.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Dec 07, 2021 - 22:35 GMT
Monitoring
We are now seeing intermittent successes for approving logins via Authy so users are able to login again. If you are unable to login on the first attempt please reattempt the login in.

We are continuing to monitor the situation alongside Authy and will provide any further updates here.

Please note: the approval may take slightly more time than usual during this monitoring time.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Dec 07, 2021 - 17:38 GMT
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 16:42 GMT
Update
We have identified that there is currently an AWS network outage across across the US east coast which is having a knock on effect for our Multi Factor Authentication (MFA) provider, Authy.

We are working closely with them to reinstate service and will be looking into alternative measures of allowing logins should the issue persist.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Dec 07, 2021 - 16:28 GMT
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 16:02 GMT
Investigating
We are aware that users of the Customer Portal and Salary Supplier Payments cannot login or make approvals due to an issue we are experiencing with the approval notifications from Authy. We are in the process of investigating this and will provide regular updates.

This is currently effecting Login approvals and payment approvals.

Please be assured that we are looking at this as a priority.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Dec 07, 2021 - 16:01 GMT
This incident affected: Modulr Customer Portal and Twilio Authy 2FA.